Unable to install WiX Toolset

When installing the WiX Toolset using: choco install wixtoolset the jobs hangs with some strange error message: e.g: https://travis-ci.org/ctron/hat/jobs/459756015


I bump in to it too.
it is a known bug in the choco package “The install of dotnet3.5 was NOT successful”.
after trying different versions I did the following:

  • choco install nuget.commandline
  • nuget install WiX.Toolset
    so I’m actually installing it from nuget instead of choco.
    try it out and tell me if it works for you.

Thanks for the idea. I tried it out, and it installed an older version of WiX (3.9), but the installation worked.

I figured out that there is a version named “WiX”, which can be installed via nuget as well. It is simply named “WiX” and brings you version 3.11 and, from what I saw, even 4.x if you like that.

Thanks for your help!

FYI, pre-installing .NET 3.5 via PowerShell command worked for me:

- powershell Install-WindowsFeature Net-Framework-Core
- cinst -y wixtoolset

powershell Install-WindowsFeature Net-Framework-Core did the trick!