Ppc64le arch support on travis-ci.com vs. travis-ci.org

It is great that there is now beta support for - os: linux-ppc64le & we are using this productively in the NumPy development repo.

However, when I try to do debug work in my own fork, which instead uses the GitHub / Travis app & travis-ci.com unstead of older travis-ci.org infrastructure, it seems that the linux-ppc64le mouseover shows up in the matrix, but the architecture of the provisioned node is actually x86-64.

See the example PR here, which demonstrates the silent switch from ppc64le to x86-64: https://github.com/tylerjereddy/numpy/pull/6


Hello, there. You have found something we have not yet announced. As such, we are unable to provide support of any kind, or guarantee that it will continue to work. If it works now anywhere anyhow, it is purely coincidental. I suggest not relying on it for the time being.



Are these two related issue? Debug mode isn't wotking in linux-ppc64le

Is the debug support for os: linux-ppc64le still not announced?