Pip is not installed in ppc64le and arm64 images

I am excited about today’s announcement about multi-arch support!!

But I found that pip is not installed in the ppc64le or arm64 images, but is installed in amd64 images.

See:
https://travis-ci.org/djlwilder/hello-world/jobs/611112179

As a workaround I installed pip like this:
[ $TRAVIS_ARCH = ppc64le ] && sudo apt-get install python-pip python-setuptools
[ $TRAVIS_ARCH = aarch64 ] && sudo apt-get install python-pip python-setuptools

But the version of pip is still not the same as on amd64:
https://travis-ci.org/djlwilder/hello-world/builds/611107621

amd64: pip -V -> 19.0.3
arm64, ppc64le: pip -V -> 8.11

I have tried this way - https://github.com/ghatwala/python-testing/blob/master/.travis.yml and travis job where pip is “19” for ppc64le/s390x/arm64/amd64 - https://travis-ci.org/ghatwala/python-testing/builds/612015314

Thank you for your reply. I found the difference between your example and mine is the language: setting. Here my job is “language: c”, your example uses "language: python.
https://travis-ci.org/djlwilder/hello-world/jobs/612055816

Apparently the python environment is different when language: python is used, that makes sense. But when language: c is used the python environment for amd64 is still not the same as the other arches.

My simple example was derived from here: https://github.com/openvswitch/ovs/blob/master/.travis.yml. This travis.yml is testing “c” code, but requires a python environment as well. How should I code in this case to insure a congruent python environment with all archs?

1 Like

Hello, as posted above and from my experience. I listed the packages I found which were installed on travis amd64 virtual machine but not on travis arm64 container:
python-pip
python3-pip
python-setuptools
python3-setuptools
python-dev
python3-dev
libtool

Again, as a result, open source projects need some CPU specific shell script to install the missing packages.

As far as I know, for different architectures and different OS distributions, it might be difficult to make everything the same especially the software version. However, It would be better to keep the installed packages as congruent as possible for multiple architectures.

1 Like

Hi @djlwilder @yzyuestc, Thanks for the feedback.
I updated the pip for language: c image, it’s the latest version now. We have planned an update on amd64 too.

More to come soon!

1 Like

Hi Damian
Thank you for the update.

arm64 images are fixed now, ppc64le are still broken.

https://travis-ci.org/djlwilder/hello-world/builds/612510759

ppc64le images are working now, Thank you for your help.

Hi Damian,

Thanks for your update @Damian. I tested the project on Arm container at travis-ci.org. It works!

Cheers

Imprint