LaTeX Error: File `inconsolata.sty' not found only on osx when building R package

Hi all,

I am experiencing problems when trying to build and test my R package using Travis CI. The package builds on my local Windows machine and via Travis CI on linux but not on osx. I am sure that nothing changed in the code that could affect building of the package, so it seems to be that something changed on the side of Travis CI. I get the following error message:

 LaTeX errors when creating PDF version.
This typically indicates Rd problems.
LaTeX errors found:
! LaTeX Error: File `inconsolata.sty' not found.

I tried to solve the issue by adding the missing package to the .travis.yml:

    - tlmgr install inconsolata

as suggested here and here but without success. Apparently, I do not have permission to install the missing package.

Do you have an idea how I can solve this issue? The full log is available here in case this helps.

Thank you in advance,


Same here, might be related to the recent switch to TexLive-2019 as the LaTeX package manager seems to fail finding inconsolata in the repository.

It looks to me like the mirror chosen was has not updated to 2019, so I think this will resolve itself naturally when the mirrors catch up. If not I can look into it.

1 Like

Thanks for your response. When do you expect that the mirrors are updated to 2019?

I had the same issue starting 4 days ago (April 29th). I solved it by forcing a previous version of TeXLive with a downgrade to OSX 10.12: osx_image: xcode9.2. I posted a thread on DevOps StackExchange.

For next year and the ones after, how about letting the users specify a TeXLive version?

I am having the same issue for the past day. I have tried installing inconsalata as suggested, however I do not have permissions.

Note that my package builds on Windows, Mac, and Linux when tested on rhub/win-builder.

The error said to mention @jeroen and @jimhester.


Same here. I am guessing that this is related to the release of TEXLive 2020.

1 Like

Same here:

Switching to xcode9.2 ( or xcode9.3 ( did not help


It appears that the problem has been resolved. I have been able to build successfully for the past couple of days.

1 Like

The problem exists for me as of May 3, 2020:

Can anyone tell me what the core issue is here? I would think that using a versioned osx image (instead the “latest” image) in Travis would effectively freeze Travis to not pick up any update to texlive or whatever underlying software is causing the issue. If not, this would seem to beat the whole point of using Travis as a reproducible environment.

1 Like

I have the same problem trying to build my R-package on Travis today.

1 Like

I have the same issue here