Default Latex install no longer works

Hi there.

Recently my builds that use R suddenly increased their runtime from around 3 minutes to over 9 minutes. The increase is entirely due to this command in the setup process of the VM which takes over 6 minutes to run:

tlmgr update --self

Not only does it take forever to run, but it fails. Here are the related log lines:

748No connection to the internet.
749Unable to download the checksum of the remote TeX Live database,
750but found a local copy so using that.
751
752You may want to try specifying an explicit or different CTAN mirror;
753see the information and examples for the -repository option at
754http://tug.org/texlive/doc/install-tl.html
755(or in the output of install-tl --help).
756
757tlmgr: package repository http://ftp.math.purdue.edu/mirrors/ctan.org/systems/texlive/tlnet (not verified: unknown)
758tlmgr: saving backups to /home/travis/texlive/tlpkg/backups
759tlmgr: no self-updates for tlmgr available.
760

It appears to me that the version of Latex is so far out of date that it cannot even update itself any longer. I was able to solve the problem by specifying that Latex not be installed (“latex: false”) in the my build YAML and then manually installing it later in the build.

As requested here, I’m tagging @jimhester and @jeroen.

I believe this is the repo that is being used for the texlive install, and it hasn’t been updated since mid 2016.

Edited to add: One other problem I noticed when trying to debug this is that somehow the mirror used for CTAN is hardcoded to a Purdue mirror that is no longer online. You can see it in line 757 above.

You can directly install TinyTeX using R via:

tinytex::install_tinytex()

Alternatively use the install script, here’s more information on that. TinyTeX - A lightweight, cross-platform, portable, and easy-to-maintain LaTeX distribution based on TeX Live - Yihui Xie | 谢益辉

I know I can. That’s what I said I did.

Look, it’s your platform. Do what you want. For myself, this sort of response reconfirms my decision to move to Github Actions.

I spent a fair bit of time debugging this, and right now anybody who uses the R build config in its default state is facing substantially increased run times, and broken software. Even if you don’t want to bother fixing the Latex install, removing it from the build config and updating the documentation would at least make the system not broken.

Edit: I just made a pull request to do that.

1 Like

Hey @jtbayly,

You can also change the repo to the following:

tlmgr option repository https://ctan.kako-dev.de/systems/texlive/tlnet/

Then call tfload:

uaotfload-tool -fu

Depending on what you’re doing, once you’ve done that you can run:

docker restart sharelatex

I appreciate the PR and I’ll take a look at it, I understand you’re frustrated and will make sure we get this sorted out.

Thank you,
Montana Mendy

2 Likes

running uaotfload, 2 days ago did the fix for me as well…

The build failed. I guess I was too hasty. The easiest fix is probably to just point to a different repo for texlive.

Imprint