API Error when trying to travis enable a github repo

When I try to flick this repo - https://github.com/shlomif/rinutils/ - in this page - https://travis-ci.org/account/repositories - I get a github API error, but all API permissions are granted:

An error happened when we tried to alter settings on GitHub. It may be caused by API restrictions, please review and add your authorized Orgs.

It seems that the case I got the same error when I tried to enable repo after I participated in additional GitHub organization.

I resolved the problem by revoking access once in GitHub and logged in again in Travis CI.
Existing Travis CI settings were being preserved.

4 Likes

Update: I can flick the repo now, so the symptoms of the issue are gone for me. Thanks!

I am also getting this error message. I am not a GitHub organization but I do participate in an external GitHub organization.

Resolved by applying smori1983’s fix.

Works for me without revoking. Just logging out and than logging in on Travis required.

2 Likes

But in the next few days I need to relogging again, no matter whether I’ve revoked or relogged

Imprint