Connection to github failure

I already activated Travis CI builds on some of my GitHub repositories, but I face an issue since a few days; I can’t activate Travis on new repositories, and I can’t deactivate Travis on existing repositories.

The error: https://tof.cx/images/2020/03/26/54e7213792c489fa5c1b697288179613.png
I revoked Travis permissions in GitHub and created new ones (https://tof.cx/images/2020/03/26/485f34265887660ddf32c23c2f263f7f.png), I also synced my account again, but I still face the same issue.

Sorry, but why are you talking about Jenkins?

Damned, sorry, I meant Travis CI, not Jenkins CI :-p
First post edited.

Check https://travis-ci.org/account/repositories and https://travis-ci.com/account/repositories

I did it already (https://tof.cx/images/2020/03/26/54e7213792c489fa5c1b697288179613.png).
I’m using .org (free account for free&opensource projects), not .com (business) Travis website.

When did you try it the last time? I don’t see any activity corresponding to toggle of jonathanlermitage/IconViewer. (It is also entirely possible that the app is exploding for some reason and it’s not logging anything.)

I tried several times today and yesterday.

I also tried this way, a few seconds ago: https://tof.cx/images/2020/03/26/de928fdd6abbb8d7dd6a4e814c61ff2a.png (the “Activate repository” button at https://travis-ci.org/github/jonathanlermitage/IconViewer)

I should have tried it first, Firefox console indicates https://api.travis-ci.org/repo/28324049/activate returns a 500 error :
{
@type”: “error”,
“error_type”: “server_error”,
“error_message”: “no GitHub token for user”
}

I am authenticated on GitHub and Travis.org, but I’ll try to delete my cookies and local storage.

That’s it: I deleted all GitHub and Travis cookies, authenticated again, and it works fine now.

1 Like

Thanks, delete cookies works for me also.

Imprint