Windows CI not starting

I have not been able to figure out why the Windows CI is not starting. It doesn’t even progress beyond the Worker Information phase.

I am trying to use Chocolatey to install Qt Creator, which I am sure will be taking a long time. But I would expect some output from that process.

Has anyone successfully installed Qt Creator or bare qmake? If so, how?

Welcome! Check here for help:

1 Like

This is amusing to know cause I have had Windows builds running just fine with a secret for several weeks now. What’s weird though is that it suddenly stopped working 4 days ago which prompted me to look for solutions.

I hope there’s a solution in sight.

Edit: just confirmed that the job started once I deleted the secret so I am impacted by this issue. Seems like something working was reverted or broken in the past few days.

Another quick update - I tried re-adding the secret token and it has started working again. So seems like the issue is fixed, with some caveats.

I’ve found that if I have a secure value in my deployment: section, Windows seems to use it fine and there are no lockups at other points. However if I use a secret in the project settings or set secure env variables in my .travis.yml then Windows locks up all output as soon as i run my first external command (cinst, powershell, etc).

I’m wondering if it’s possible to set secure values later in the job rather than as top level variables available all the way through a job? Something like:

  - secure: <encrypted variable>

so that the encrypted variable only gets looked at during the script phase?