Travis don't run automatically

Hello, I config Travis and all is ok, but Travis doesnt run CI automatically, the only way to run a build is “trigger a build” is dashboard. How can I change that?

Github repository: https://github.com/fagustin07/repo-pruebas
Travis report: https://travis-ci.org/github/fagustin07/repo-pruebas

I reckon either push builds and/or PR builds are disabled in Travis settings for this repo, or Travis intergration isn’t set up properly.

The easiest fix (after checking Travis settings) should be to reset Travis integration:

If that doesn’t help, uninstall the Travis for Open Source Github app from your Github account then re-establish Github integration at https://travis-ci.org .

If the above doesn’t work, there’s various reasons, possibly .travis.yml is not in your root directory, also making sure your .yml file is good to go, you can use yamllint via:

brew install yamllint 

Or you can use pip

pip install yamllint

Alternatively you can use the config explorer: https://config.travis-ci.com/explore

Imprint