No new builds being triggered

Hi all, appears to be stuck at a build from two weeks ago, while contains many new commits.

I don’t see any indication of what might be wrong. Anyone got any clues?


  • Nicolas

Hmm. The GitHub integration appears to be off. Could you try disabling and re-enabling Travis CI on this repo?


Thanks for the feedback. I went to GitHub’s Settings > Integration & services > Manage Travis CI, and clicked the Test service button. A new build has now been triggered on Travis CI. So let’s see if it also keeps doing so for new pushes.

Looks like it’s still not triggering builds on new pushes.

I tried unchecking Active in the GitHub’s Manage Travis CI page, but it gave me an error: “There was an error updating your hook: These events are not allowed for this hook: membership”

Then I noticed the note: “GitHub Services are being deprecated. Please contact your integrator for more information on how to migrate or replace a service with webhooks or GitHub Apps.”

I’ll look into those alternatives.

We have GitHub Apps integration out, so you might want to try that first.

Google’s policy does not allow the GitHub Apps integration, because it requires write priviliges that we can’t grant for security reasons. I’ve reached out to our open-source support team to find another way to re-enable Travis CI.

I tried re-enabling the hook on our side, and it seems to have worked. Could you try pushing a new commit?


Hi @c0d1f1ed, thanks for the issue report.

This membership problem is related to a GitHub v3 API misunderstanding where we asked for membership events, but that event type does not exist. The best path forward (for future reference) would be to delete the service hook altogether and use our website to add the integration back.

As for GitHub Apps, that is the new integration type we use on I would love to understand what you mean by Google’s policy does not allow the GitHub Apps integration, because it requires write priviliges

Our GitHub Apps integration does not ask for write permissions, but our login does. This is something we will be addressing very shortly as we do not want write permissions, the less permissions the better.

If there is someone we can talk to at Google to have this clarified, we would love to be put in touch.

Thanks a bundle


Hi @josh, I’ll try to get the full rationale from our GitHub integration support team and see if we can make things work with the GitHub Apps approach.

I can tell answer @josh’s question: Your site has a great big green button for integrating your Github account with Travis, that when you click it, demands write permission to all public & private repositories. I would never allow for that, so I’m here digging around your forum trying to figure out if there’s a workaround.

Hi, I am facing the same problem that @c0d1f1ed experienced before.

Previous 50 commits, all successfully triggered Travis to build. But, just today Travis is not building anymore after commits. This is my repo EWWB. I can manually trigger build inside Travis, but git commits won’t trigger Travis anymore.

Don’t know what happened, but it’s triggering now. After manually triggering about 5 times, and I also tried to edit the .travis.yml (cause that’s what I’ve read maybe the indention, etc), it is now working again. Really don’t know the root cause though.

@MelodicCrypter you had a lot of jobs being queued, and additional ones had to wait.