Pushes won't trigger new builds anymore after the project has been inactive for a long time

After not pushing anything for 10 months, new GitHub pushes won’t trigger builds on Travis anymore.
I can trigger new builds manually, which will work (but only for branches, tags cannot be triggered manually).
10 months before, builds were triggered just fine, and I have not changed anything since then.

Here is a link to the Travis project.

Things that I have already tried, to no avail:

  • Revoking the "Travis CI for Open Source* OAuth application on GitHub, and re-adding it.
  • Disabling the Travis GitHub webhook, and re-enabling it.
  • Manually re-triggering the Travis GitHub webhook.

Please note that my GitHub organization also contains many more repos. I have not yet tried if automatic builds work for the other repositories.

Most probably, Travis webhook changed in these 10 months in a backward-incompatible way (I do remember topics that suggest so: GitHub services to Webhooks migration update, No new builds being triggered, Double builds for all merges and PRs).
So you need to:

  1. Disable CI for the project in https://travis-ci.org/account/repositories
  2. Look through Webhooks and Integrations & services in Github project’s settings and delete anything Travis-related
  3. Re-enable CI for the project
1 Like

Great, that seems to have worked!

For other users with the same problem:

Just disable the project on Travis, as described above. Then on GitHub, go through the project settings and remove or disable everything that has Travis’ name in it. Especially the Travis webhook. Then, re-enable the project on Travis.

In case you are asking yourself if you also need to remove the Travis permissions on the organization/user level – no need for that. Only concern yourself with the GitHub project settings, not with the level above.