PRs started failing on 6/12

Hello!

I run the Timber project and we use Travis heavily to validate our PRs, etc. Yesterday starting at around 1pm Eastern US Time (June 12, 2019). All of the new PR builds started to fail, some examples:


https://travis-ci.org/timber/timber/builds/544916379


https://travis-ci.org/timber/timber/builds/544886496

Nothing in these PRs changed Travis or other setup scripts. What’s very strange is that the current master still builds properly (when I re-run one of these builds):

https://travis-ci.org/timber/timber/builds/539249629

Even stranger, OLD PRs (submitted before 6/12) build successfully when I re-run tests:


https://travis-ci.org/timber/timber/builds/544238623?utm_source=github_status&utm_medium=notification

I thought: there must be a change to the Travis or test scripts that I’m just not seeing. So I branched master and made as superficial change to the readme. The result? Failing test:


https://travis-ci.org/timber/timber/builds/545324749

This tells me it’s nothing with the repo’s scripts or code. But something in the config, GitHub or Travis execution.

Has anyone encountered anything similar? Does anyone from Travis have any ideas?

Solved! It looks like Travis changed the default dist from trusty to xenial. Not sure why, but it seems Xenial (Ubuntu 16.04) doesn’t have the right perms for MySQL. Specifying Trusty did the trick!

https://docs.travis-ci.com/user/reference/overview/

I don’t see services: mysql in your config.

We don’t start MySQL by default now on Xenial. You need to explicitly specify it.

1 Like

Thanks so much @native-api and @BanzaiMan! I’ll specify Xenial and MySQL — really appreciate the (quick) answers!

Imprint