Osx builds on travis-ci.com start to fail with 'An error occurred while generating the build script.'

We are experiencing this non-descriptive error on jobs as of earlier today. We tried different osx_image values. Some of the jobs do work, but around 50% of the jobs fail. Restarting sometimes results in a working job, but not always.

It feels like something fishy is going on on travis-ci.com?

We’re seeing the same issue over here. I would say 2 in 3 of our builds are failing with “An error occurred while generated the build script.” Have tried xcode12.2 and xcode12u for the osx_image field with no luck.

Possibly I should create a new thread for this. Apologies if that was the case.

I see exactly the same error in some of our builds. Example job that fails:


It’s one of 2 OSX jobs in our matrix. The other one always seem to sail through. It isn’t reproducible as this job was part of a test-run on a PR where the previous test-run. The relevant commit only changed our .zenod.json (which isn’t part of the tests).

Here’s our .travis

Had a support case for this, parallel to this, which just got resolved and I can confirm it’s working for us again on xcode12.2 image.

1 Like
Imprint