After migrating to travis-ci.com (from org), I get "An error occurred while generating the build script." on MacOS

Here is the build:

This happens each time, repeatedly.

While we were on Travis-ci.org, all was working fine!
Then, after migrating, this started happening.

1 Like

I had warning regarding build config that I am missing root lvl “os:” declaration and that default “linux” is used. While that was causing no problems on .org, I still decided to try to fix that, just to be sure. After I fixed it, macOs build passed! I am still somewhat suspicious that this helped, but I have nothing else to go after, so I am assuming this helped in some indirect way. I would still expect macOs build to not fail as it did.

1 Like

For me the issue isn’t fixed. I was already using .com before, but now I have the issue for no reason (which makes me think that the problem comes from the infrastructure rather than my side). I tested different configurations (including ones that previously worked).

1 Like

Solution doesn’t work for me. Actually, exactly same config works on one branch and fails on a different branch with:

An error occurred while generating the build script.

Works: https://travis-ci.com/github/igsilya/ovs/jobs/440598842
Doesn’t work: https://travis-ci.com/github/igsilya/ovs/jobs/440598867

1 Like

We also started getting this error on .com with one of our private repos on Saturday and reached out to support now. Fwiw, our build worked on Friday and no changes have been made on our side since then.

2 Likes

We were also seeing an issue in the past few days related to a similar "An error occurred while generating the build script.”. The issue was happening because osx_image: xcode12.1 was removed from travis without any notification to travis users so the fix was changing to osx_image: xcode12.2

1 Like

In my case only one of the two macOS jobs fails. The difference between them is that nonfailing one sets up different env and uses hombrew addon. Neither should be a reason for build failure. Both are using osx_image: xcode11 so it doesn’t exactly match with theory above.

This means it’s

And in our case the error just disappeared after a couple days. Even restarting those failed builds succeeded.

Imprint