[Migrating to travis-ci.com] Migration is not available for this account

Hi all,

I am trying to move my repositories from .org to .org. What I have done:

  • Logged in to travis-ci.com with the exact same Github account as on travis-ci.org
  • Signed up for the beta on .org
  • Authorized GIthub apps (only future repositories appear in the authorization… why?)
  • Both Activated and deactivated the “Legacy Services Integration” for the concerned repos
  • Double-checked that my username has admin access to these repos on GIthub
  • Tested with another Github account having admin access to these repos but no travis-ci.org account

But still travis-ci.com reports that migration is not available for this account. What could be the issue and/or how can I get additional debug info?

image

Hey,

Please make sure you have selected your account (personal/organization) first from the left side menu then you have signed up for a beta feature. Choosing between your accounts will change the url as well so you need to sign up for a beta feature separately for each account you have integrated with Travis CI.

Thanks,
Mustafa

Thank you @mustafa

Now it works. As far as I understand the user needs to be member of the organization with an admin role, the “Signup for the beta” button must be clicked for this specific organization and then migration can happen.

Now I could migrate I’ve just triggered a build on the migrated repos but I get You tried to trigger a build for xxxxxx/xxx but the request was rejected.
From the web I read that to fix this issue a plan with enough remaining credit must be selected. This is my case already I have a brand new free plan with 10000 credits. Any idea?

Hey @yoan,

Can’t say anything without knowing the repository name.

Thanks,

Hi @mustafa

Actually that’s an issue identical to latest posts from this thread. Yaml file is present, Free plan is selected with 10000 remaining credits but build is still rejected with no additional info. My case also relies on a Github repo.

Imprint