Jdbi3 maven build with spring-core 5.x consistently times out


#1

I’ve been trying since over a month ago to add a maven module to jdbi for Spring 5 support. We already have Spring 4 integration. The build works fine locally and the integration itself isn’t much more than just an added mvn module that sets a different dependency version, but travis just isn’t able to build it.

The build on travis always times out on the exact same problem that I cannot reproduce and that leaves no error messages: on installing a spring dependency called xmlunit-core from Central (or at least, that’s the last thing the build logs before stalling). See here for the latest occurrence.

I ran the build dozens of times and it failed almost every time in the exact same way (now and then a build suddenly passes but then it breaks again the next time). Clearing the build caches did not help. Different patch versions of spring-core don’t help. Playing with the settings, turning things on or off, hasn’t helped.

I just cannot find any consistent cause for the build failure other than “spring 5 is a dependency”… I’d almost suspect the compiling java process is just running out of memory, but then that should leave signs according to what I read about travis builds online.

Does anyone have a clue why this might be happening or how to fix it? Thanks for any help.


#2

PS: what’s even more strange is that only one of the five jobs in a build fails. It’s always the code style build. That screams “compatibility issue”, but what could it possibly be, and more importantly why would it work fine when I run the same build on my windows machine?