Issue getting my project to build

I am not sure if there is a syntax issue with my yml file, or if I am not following the instructions to get a build to trigger. I’ve tried committing a change to a file in a branch after the yml file has been pushed to master, but no luck. I am very new to this, hoping I’m missing something simple.

Hey @danikban,

Your .travis.yml file should read more like this:

---
language: node_js
node_js:
  - node
  - lts/*
cache:
  directories:
    - ~/.npm
    - .jest
before_script:
  - npm install -g npm@latest
script:
  - npm ci
  - npx jest --ci
jobs:
  include:
    - stage: deploy
      node_js: lts/*
      script:
        - npm ci
        - npx expo login -u $EXPO_USERNAME -p $EXPO_PASSWORD
        - npx expo publish --non-interactive

That being said, the .yml file you provided is valid .yml.

Happy building!
Montana Mendy

@Montana I’ll look into your suggestions, but for now I’m just trying to get it to build. If my .yml file is valid, what would prevent travis CI from recognizing I’ve created a new pull request and trigger a build? It’s not even recognizing in my dashboard that I’m creating pull requests.

Hey @danikban,

So it’s valid in the sense it’s formatted correctly, I ran your .travis.yml file locally (with your files), and got this popped back while running it verbosely:

[warn] on notifications: unexpected sequence, using the first value ({:slack=>"nyu-agile-software:4Ll9V7RPK8fkqf2dGDvWiEGt"})
[info] on root: missing os, using the default "linux"
[info] on root: missing dist, using the default "xenial"

I hope this helps, you can do this in a easier way via a GUI:

https://config.travis-ci.com/explore

You might also want to check your env var's.

Happy building!
Montana Mendy

Hey @danikban,

Here’s some official documentation from Expo.

1 Like
Imprint