Fails to report build status to GitHub

Hey there,

since the maintenance on Friday, Travis CI does not report build statuses to GitHub (but builds run without problems). For example:

I tried to disable and re-enable Travis for this repo. However, disabling failed:

" An error happened when we tried to alter settings on GitHub. It may be caused by API restrictions, please review and add your authorized Organizations."

error

Clicking that link shows GitHub saying that everything is okay (and the only thing I did during Travis maintenance was to create a new PR - no new repos, no permissions modified):

(I am not allowed to post this screenshot since I am a new user, so just believe me when I claim it shows everything is okay.)

Thanks for any suggestions and stay safe&healthy,
Uli

2 Likes

Hey @psychon,

Have you tried to resync Travis?

What exactly do you mean?

If you mean “Sync account” on https://travis-ci.org/account/repositories: Yes, I tried that even before I noticed that I cannot disable TravisCI on my repo.

If I point at the button (no clicking, just hover), right now it says “Last synced a day ago”. Before that, it said something about having last synced on Friday (I do not remember the exact wording and I did not do anything myself on Friday).

I had the same issue, I did a hard reset of the GitHub/Travis link and now it works again.

See: Travis UI does not link a build to correct commit on GitHub PR

1 Like
Imprint