GitHub PR is being built but result is not shown

I have Travis CI set up on a GitHub repository to build the commits to every PR. This worked fine until ~2-4 weeks ago. I noticed that within a PR the result of the building process is not shown within the PR. I thought I might have messed up the configuration or something else.

Today, I came around to try to fix this and found that the commit is correctly build by Travis CI, but the result is not reported back.

Example:

PR: https://github.com/pmeier/pystiche/pull/40

Travis CI build: https://travis-ci.org/pmeier/pystiche/builds/642793488

Does someone have an idea what is going on?

We also encountered the problem, travis-ci did not report the build status:

continuous-integration/travis-ci Expected — Waiting for status to be reported

We solved it after some operations, you may have a try:

  1. Revoke authorization of travis-ci from github:
    Go to https://github.com/settings/applications, find “Travis CI for Open Source” row and click “…” then click the dropdown “Revoke” button.

  2. Reset Access of “Travis CI for Open Source” (I’m not sure if this is necessary): Go to github organization home page and click “Settings” - " Third-party access", find the “Travis CI for Open Source” and click the “Edit” button, then it will jump to “Access Review” page, my url like this https://github.com/organizations/hugegraph/settings/oauth_application_policy
    https://github.com/orgs/hugegraph/policies/applications/1508
    click “Deny access” then click “Grant access”.

  3. Re-authorize travis account:
    Go to https://travis-ci.org/, and sign out the account, then click “Sign in with GitHub”, and it will jump to “Authorize Travis CI for Open Source” page, click the green “Authorize travis-ci” button. Well everything is done.

It works fine for me.

3 Likes

It worked, thanks. Mind that I can’t confirm if step 2. is necessary, since I’m not part of an organisation.

I can confirm that was not necessary in my case. Revoking access and authorising it again fixed the issue.

It worked too for the chess engine Stockfish, thanks a lot!

Imprint