Can't authorize a GitHub organization

Hello!

I work for a small non-profit organization. We have a GitHub organization and I’m trying to enable Travis CI for it. Now I don’t personally have administrative access to the GitHub organization, and what happened was that I tried to enable builds for a repository within the organization and then discovered that I needed to allow access from Travis CI. From my personal Travis CI account (linked to my GitHub account), I clicked the link to request access from the organization owner and, unfortunately, the organization owner missed the email asking for access. Fast forward to a few weeks later, and the organization owner is now trying to authorize the request. She claims that she has allowed Travis CI, but on the Travis CI side the organization doesn’t show up.

I’ve tried, from my personal Travis CI account, to request access again, but the link that I would normally use to request access just says “Access request pending”.

I’m at a loss as to what to do: I can’t update or revoke the access request, the GitHub organization owner claims to have allowed access, and yet we still can’t access the GitHub organization from Travis CI.

Any help would be appreciated!

Imprint