Cannot add my GitHub organization to my account in Travis CI

About a month ago I got this notification at Travis CI - Test and Deploy with Confidence
“Builds have been temporarily disabled for public repositories due to a negative credit balance. Please go to the Plan page to replenish your credit balance or alter your Consume paid credits for OSS setting.” (I use OSS/free plan…)

I navigated to my “Settings” (AKA “Profile”) at Travis CI - Test and Deploy with Confidence and noticed that “You are not currently a member of
any organization”.

Using a link: Review and add your authorized organizations.
I tried several times to make my GitHub “andstatus” organization (where I’m the owner) visible to Travis CI. I installed and uninstall Travis app… at Github, refreshed my profile page at Travis CI - Test and Deploy with Confidence, pressed “Sync account” button several times… but the organization still doesn’t appear.

Please help!

PS: I see that I can add my personal Github repositories to Travis, but this is not what I need :frowning:

Some magic happened: Previously I tried everything via Google Chrome, but now I tried MS Edge - and without ANY changes I do see my “AndStatus” organization:

Then I refresh Chrome browser window - and I do see the same organization there…
So this looks like some incompatibility with Google Chrome (Chrome is up to date
Version 109.0.5414.75 (Official Build) (64-bit) )