Build can't find r-cran-xxx binaries

My R package has stopped building because it can’t find r-cran-xxx binaries in both r-stable and r-devel. Looking at the log, the PPA ppa:marutter/rrutter4.0 is being added but none of the the list of packages I’ve put under r-binary-packages are found. For example:

E: Unable to locate package r-cran-curl

The full log is here:
https://travis-ci.org/github/ImperialCollegeLondon/safedata/jobs/688323701

I suspect this is to do with moving from R3.x to R4.0 and caching, but I’m not clear what I need to do.

Many thanks for supporting Travis and R!
David

Hello @davidorme,

Have you tried adding this package in your config?

r_packages: devtools

I have just tried that, and also commented out the cache: packages in my .travis.yml file, but I’m still getting the same issue:

https://travis-ci.org/github/ImperialCollegeLondon/safedata/jobs/688712061

From earlier builds, it looks like source R packages (r_packages) get installed after binary ones (r_binary_packages), so it looks like adding devtools is downstream of the issue?

Did you check if the binary packages you are trying to install actually exist?

E.g. googling “apt r-cran-assertthat” and looking at the PPAs that the build installs suggest that it’s expected to be present in Ubuntu stock repos. It is, but its only available since Bionic while you are using Xenial.

Aha. In previous builds (before R 4.0), I think all the r-cran-xxx binaries were coming from the first PPA in the build list (ppa:marutter/rrutter3.5). That has been replaced by a new PPA (ppa:marutter/rrutter4.0) which seems to have many fewer packages available. If those packages have been moved to Ubuntu stock in Bionic, then that fits - using the new version of R on the older Ubuntu version leaves a gap.

It seems like the default dist setting is Xenial, so I think I need to add dist: bionic to my config to fix this.

1 Like

OK. I spoke too soon. That didn’t work.

https://travis-ci.org/github/ImperialCollegeLondon/safedata/jobs/689273261

WTH? You are not getting Bionic! Another missing image?

I guess you can try installing those packages from CRAN (via r_packages:) instead as a workaround…

I’d missed that I was still getting Xenial. That explains why it didn’t fix it. Something weird going on.

Ah. Same as this issue, I think. Everything has shifted to 4.0 and the PPA isn’t populated yet. It seems like I can wait for the binaries or shift to source packages (assuming I can’t get bionic).

Also, I’ve checked the build details from another recent question that mentioned bionic and that also specifies dist: bionic but gets Xenial:

https://travis-ci.org/github/richelbilderbeek/mcbette/jobs/624489543

Imprint