Build can’t find r-cran-xxx binaries

@jeroen @jimhester A wide selection of binary R packages used to be available from ppa:marutter/rrutter. Are these packages planned to come back? My builds have been broken since May (example).

Thank you.

It’s better to avoid the r-cran-xyz packages on travis, and just install them from source. The problem with the r-cran binaries is that they only work for the latest version of R, whereas on Travis you can pick any R version.

The problem is that Travis has a time limit of something like 45 minutes. Some packages have a lot of dependencies that can take a long time to install.

I guess what you’re saying is that I don’t have a choice? r-cran-xyz packages aren’t coming back?

Can you point to me an R example of a two stage build? I can’t follow the Ruby code from the manual example.

Okay, I got it working, https://travis-ci.org/github/OpenMx/OpenMx/builds/702504029

They r-cran-xyz packages for R 4.0 should be available again after this gets merged: https://github.com/travis-ci/travis-build/pull/1921

Imprint