Bionic builds fail, getting Xenial instead

Hi @jeroen and @jimhester,

Since approx 12:45 (UTC+1) Travis builds for Bionic fail.

For example, from this Travis build log I read Xenial is used:

R session information

1.64s$ sudo add-apt-repository -y ppa:opencpu/imagemagick

6.94s$ sudo apt-get update

Hit:1 xenial InRelease
Hit:2 xenial-updates InRelease
Hit:3 xenial-backports InRelease
Get:4 xenial-pgdg InRelease [56.4 kB]

At the top of my .travis.yml file it can be found I use bionic:

language: r
dist: bionic
cache: packages

Also when I re-build a package that built successfully, I get the same error.

For completeness I add the error that I predict follow naturally from this problem:

Ign:15 xenial-pgdg/main i386 Packages

Get:14 xenial-pgdg/main amd64 Packages [115 kB]

Err:14 xenial-pgdg/main amd64 Packages

  Hash Sum mismatch

Fetched 149 kB in 0s (188 kB/s)

Reading package lists...

E: Failed to fetch  Hash Sum mismatch

E: Failed to fetch  Writing more data than expected (209052 > 209044)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Happy to help and good luck fixing this :+1:

I just found out, this is not specific to R, also C++ projects fail.

Problem is solved, everything builds successfully again.