API builds are incorrectly using Ruby even though other languages are specified

My job failed since 3 hours ago, and failed with:

No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb, Rakefile.rb)
/home/travis/.rvm/gems/ruby-2.4.1/bin/ruby_executable_hooks:15:in eval' /home/travis/.rvm/gems/ruby-2.4.1/bin/ruby_executable_hooks:15:in<main>’
(See full trace by running task with --trace)
The command “rake” exited with 1.

see job: https://travis-ci.org/blademainer/google_containers_mirror/builds/509422239

It’s looks like a language detect bug?

Succeed job’s language is: Shell

And failed job’s language is: Ruby

I’m running into the same issue: https://travis-ci.org/mozilla-iot/addon-builder/builds/509506969 (language incorrectly detected as Ruby)

It was working fine yesterday: https://travis-ci.org/mozilla-iot/addon-builder/jobs/509116301 (language correctly detected as node_js)

I ran travis lint on my local machine and it reported:

[x] in os section: dropping osx, does not support node_js

Removing osx from from my .travis.yml file allowed it to run. It seems that if there are any parsing errors in the .travis.yml file that it reverts to ruby. See: https://github.com/travis-ci/travis-ci/issues/9150

So it looks like travis dropped support for osx? or node_js under osx>

I tried travis lint on your .travis.yml and it looks valid, so I’m not sure what the issue is there.

Hello, there.

API builds are incorrectly configured to use Ruby. We are working on a fix now.

Thanks for the reports and your patience.

The issue should be fixed now. Unfortunately, the affected builds will not be reconfigured. If you are seeing this issue, please trigger new builds.

Thanks.

@BanzaiMan @dhylands OK. Thank you all.

Imprint