Xenial not wanting to start xfvb

The calling job (Once switched to xenial), does not like to even start up xfvb

The PR has very little code-tweaks in it. So you can see we pretty much only changed this.

PR: https://github.com/natritmeyer/site_prism/pull/368/files

Travis Results: https://travis-ci.org/natritmeyer/site_prism/builds/495981778?utm_source=github_status&utm_medium=notification

$ export DISPLAY=:99.0
0.01s$ sh -e /etc/init.d/xvfb start
sh: 0: Can't open /etc/init.d/xvfb
The command "sh -e /etc/init.d/xvfb start" failed and exited with 127 during .

Update - I’ve got this to work, but only through a bit of trial and error / luck.

Think there needs to be a bit more info / signposting on this.

The previous commands (export display / sh -e), now need writing as (For Xenial)

services:
  - xvfb

EDIT: For visitors; see https://github.com/natritmeyer/site_prism/pull/368/files

1 Like

That bit is explained in our docs: https://docs.travis-ci.com/user/gui-and-headless-browsers/#using-xvfb-to-run-tests-that-require-a-gui.

That’s correct. However to find out that info was quite tricky and wasn’t very well signposted. It took weeks of googling.

Might be worth either looking into the SEO there or something

However, the docs still say that the /etc/init.d/xvfb start way should still work: https://docs.travis-ci.com/user/gui-and-headless-browsers/#using-xvfb-directly

I still get the same error even with:

services:
    - xvfb
$ xvfb-run ./travis_build_test.sh
xvfb-run: error: Xvfb failed to start

Any ideas?

Link: https://travis-ci.org/higlass/higlass/jobs/563206126

You shouldn’t be directly executing anything with xfvb. It just runs in the background so you can do things like selenium testing.

Imprint