Failed to connect to Mir on Travis Server

I have a Tycho build w maven, I keep getting this error when deploying

Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Could not connect: Connection refused

The server logs:

 xauth is already the newest version (1:1.0.9-1ubuntu2).
```xvfb is already the newest version (2:1.18.4-0ubuntu0.8).

I dug down and found the Eclipse Docker "gist" the gist Issue states  

export DISPLAY=:0.0``` might help, so I tried:

before_install:
   export DISPLAY=:0.0

Which gets executed, but the exception still gets thrown. any ideas would be helpful?

Sounds like an xvfb problem inherently. Set the right values for the DISPLAY environment variables So something like:

services:
  - xvfb

Here’s more on HBT, would read the documentation on this. GUI and HBT. This should solve your problem and your Maven/Tycho build will pass. Let me know if you need any more help.

thank you! after reading that article, and running xvfb in services in yml, worked fine

Great,

Anything else you need don’t hesitate to come back!

Imprint