Unable to install snap on non-amd64 builders

Build: https://travis-ci.org/fnordahl/cdbc/builds/619472894

The build consequently fails on non-amd64 architectures after adding a snap dependency. I have tried dist bionic and I have also tried to upgrade packages in the image prior to using sudo snap install snapcraft as part of the install phase.

Excerpt from Travis config:

sudo: required
language: C
  - amd64
  - arm64
  - ppc64le
  - s390x
os: linux
dist: xenial
    - name: snapcraft
      confinement: classic
      channel: edge

Log excerpt:

Installing 1 Snaps
$ sudo snap install core
error: cannot perform the following tasks:
- Setup snap "core" (8042) security profiles (cannot setup udev for snap "core": cannot reload udev rules: exit status 2
udev output:
- Setup snap "core" (8042) security profiles (cannot reload udev rules: exit status 2
udev output:
The command "sudo snap install core" failed and exited with 1 during .

Update: As of today installing snaps works fine on amd64, arm64 and s390x
Build: https://travis-ci.org/fnordahl/cdbc/builds/621103973

I still see the issue on ppc64le
Build: https://travis-ci.org/fnordahl/cdbc/jobs/621096989

Hi @fnordahl
Thank you for the report.
Please check now ppc64le should also work.

Happy building.

1 Like

Confirming that snap install works for all archs including non-amd64 (arm64 ,ppc64le ,s390x) as well on xenial and bionic distribution

Travis job link - https://travis-ci.com/ghatwala/checking_snap_travis_install/builds/140941343