Ubuntu 22.04 (Jammy Jellyfish)

Ubuntu Jammy 22.04 was released in April 2022.

Please add Jammy to Travis CI.

1 Like

Hi @jdanek,

We are currently in the process of preparing this image. It will be available soon.

2 Likes

Thanks for providing Ubuntu 22.04.

It comes with all recent Python versions, but it lacks support for any PyPy3 version.

Can you add versions PyPy3.9, PyPy3.8 and PyPy3.7 (preferably the latest version PyPy3.9) from Download and Install | PyPy ?

Hey @lschoe,

I’m currently looking into this problem. This might be something to do with how we name things, but this will be sorted out. For now the following:

python: pypy3.9-7.3.9

In your .travis.yml will get your builds up and running again. I will keep you posted when we get the situation fully fixed.

Below is a sample build I made this morning with the current config described as above, and it passes.

2 Likes

Thx, @Montana, it works great.

I’ve used pypy3.9-7.3.9 as you suggest. Are pypy3.8-7.3.9 and pypy3.7-7.3.9 also available? People may want to use these because pypy3.9 is still in beta.

So, I’m actually looking at Python versions to see which PyPy versions are available on jammy/focal/bionic/xenial. Looks like the latest PyPy versions are not yet listed there.

Currently, only amd64 is supported for Jammy? I tried arm64 and there I got that jammy is invalid value for dist.

I have also triggered builds for those versions;

Please give it a couple of hours to be available.

Thanks

1 Like

Some of the variants are still in progress so please give it a couple of more days.

Thanks.

Thanks @mustafa, I’ve now successfully used pypy3.8-7.3.9 on bionic (AMD64).

python: pypy3 is also available.

Could you please look into the following build failures: Travis CI - Test and Deploy with Confidence

They seem to be env-specific.

Log:

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:
The following packages have unmet dependencies:
libudev-dev : Depends: libudev1 (= 249.11-0ubuntu3) but 249.11-0ubuntu3.4 is to be installed
E: Unable to correct problems, you have held broken packages.

1 Like

@HappySeaFox I have got the exact same problem, seen here: Build

Trying to install libsdl2-dev seems to cause the problem.

Other users on jammy had the same problem but it seems as if it was fixed upstream. bugs.launchpad

It would be great if someone could look into this!

@VectorWolf One of my recent builds succeeded, so I guess the issue is fixed.

1 Like