Trigger build doesn't work

Hi,
I can’t execute trigger build for the new branches in my project.
Travis shows me only old branches https://travis-ci.org/CorfuDB/CorfuDB

travis.yml looks ok https://github.com/CorfuDB/CorfuDB/blob/master/.travis.yml

To check that the problem on travis-ci side I have cloned corfuDb, created a branch (patch1), and tried to execute trigger build, it showed me my new branch. So, travis.yml can’t affect travis.
https://goo.gl/ymjXKJ

Can you please help me solve the issue?

What new branch is missing from the drop down list?

stream-log-metrics-enhancement for instance

The drop down list includes only the branches that have any build. stream-log-metrics-enhancement is currently excluded and has no builds, so it does not show up.

Also reported as Branches don't show up in the API Build Web UI unless a build has already been triggered on that branch.

I’m marking this as “solved” in favor of the other topic.

1 Like

@BanzaiMan could you clarify your answer a little bit? A have 2 questions:

  1. Why the branch is excluded (has no builds), how you figure out that? Even if I create a new branch it will not appear in the dropdown list.
  2. Why if I fork the repo and create a new branch it will show up?
  1. https://github.com/CorfuDB/CorfuDB/blob/0f0cd11a42ce6c0713aae6270a7963e2139885ec/.travis.yml#L11
  2. What fork are you talking about?
  1. We run build if a branch is not a master branch, should work, right?

  2. Sorry for confusion https://travis-ci.org/xnull/CorfuDB you can see that branch patch1 showed up

  1. Oops. Sorry. You’re right; that condition does not exclude the stream-log-metrics-enhancement branch. But that branch no longer exists. https://github.com/CorfuDB/CorfuDB/tree/stream-log-metrics-enhancement
  2. https://travis-ci.org/xnull/CorfuDB/branches shows that the patch1 branch has builds, so I expect that to show up in the drop down list.

Oh, looks like trigger build depends on setting build pushed branches which is strange)
image

When I activated it, my branch test_test (I just created it for testing) was triggered and showed up in dropdown list.

So, for some reason a build must be triggered and after that it will be added to the dropdown list, but this doesn’t work if we enable builds only for pull requests and maybe my settings affected this logic somehow, and combination of conditions in .travis.yml and disabled setting build pushed branches causes this problem

Imprint