Travis sending emails even though email: false in yml

In the last couple of days, I’ve received a handful of emails from Travis for Submitty/Submitty when a branch finishes building, even though email is set to false. My .travis.yml file can be found here.

For example, I just got an email for the completion of this build.

I’m having the same problem. This is definitely a recent issue as this was not a problem last week.

We’re having a similar problem, Travis is sending notifications for Pull Requests builds even though we specify on_pull_requests: false. Link to our full config. This affects many of our repositories.

It has started on Friday, previously the notifications did not appear.

Thanks for the report. We’ll take a look shortly.

We’ve pushed some potential fixes today. If you have seen this issue after Sept 30 15:26:50 UTC, please report with the build URL. Thanks.

Hi, I’m experiencing this issue currently. Link is https://travis-ci.com/LaunchPadLab/prosci_learning_center/builds/143973918. Let me know if there’s any more info I can provide that would be helpful!

Can you share the configuration? Our record indicates that you have

notifications:
  email:
    enabled: false

which is incorrect (and results in the default behavior).

What you want is:

notifications:
  email: false

Yeah, that’s odd, I also see enabled: true in the Build Config JSON object, but I’ve confirmed the yml file itself just has email: false.

I’ll attach a screenshot below.

The resulting build config:

I think the discrepancy is due to your enabling config validation. (I was unaware of the normalization.) Does the email still fire if you disable the validation in https://travis-ci.com/LaunchPadLab/prosci_learning_center/settings?

Did you toggle the validator setting on this repo recently? I see several builds over the last few days, but only a few of them (96, 97, 98, 99, 102, 103) sent email. These are all on the rich-text-content branch. Please confirm this.

This one corresponds to build 104, a PR build on the dev branch, and did not fire email.

Hmm, I wasn’t aware of toggling that option. It’s possible one of my colleagues did though. I’ll un-toggle the option and see if that fixes the issue.

I’ve been seeing the same issue since a few days. I’m sure that I never enabled “build config validation”, and I’m the only one with repo access.

The config is also verified as correct btw:

language: go
go:
  - '1.13.x'
go_import_path: 'zgo.at/goatcounter'
env:
  - 'GO111MODULE=on'
cache:
  directories:
    - '$HOME/.cache/go-build'
    - '$GOPATH/pkg'
notifications:
  email: false
before_cache:
  - 'rm -rf $HOME/.cache/go-build/log.txt $GOPATH/pkg/mod/cache/vcs'
script:
  - 'go vet ./...'
  - 'go generate ./... && [ $(git status -s | wc -l) -gt 1 ] && git diff && exit 1 || true'
  - 'go test -race -coverprofile=coverage.txt -coverpkg=./... ./...'
after_success:
  - 'bash <(curl -s https://codecov.io/bash)'
{
  "go": [
    "1.13.x"
  ],
  "os": [
    "linux"
  ],
  "env": {
    "jobs": [
      {
        "GO111MODULE": "on"
      }
    ]
  },
  "cache": {
    "directories": [
      "$HOME/.cache/go-build",
      "$GOPATH/pkg"
    ]
  },
  "script": [
    "go vet ./...",
    "go generate ./... && [ $(git status -s | wc -l) -gt 1 ] && git diff && exit 1 || true",
    "go test -race -coverprofile=coverage.txt -coverpkg=./... ./..."
  ],
  "language": "go",
  "before_cache": [
    "rm -rf $HOME/.cache/go-build/log.txt $GOPATH/pkg/mod/cache/vcs"
  ],
  "after_success": [
    "bash <(curl -s https://codecov.io/bash)"
  ],
  "notifications": {
    "email": [
      {
        "enabled": false
      }
    ]
  },
  "go_import_path": "zgo.at/goatcounter"
}

Which repository is this for, and when did you receive it?

Thanks; the repo is https://github.com/zgoat/goatcounter, and the first email I got was today at 16:36 UTC +8, roughly 5 hours ago (I thought I had some yesterday as well, but looks like I didn’t; it’s been a few very busy days :sweat_smile:).

Thanks for the info. We’ll take a look. Sorry for the confusion here.

Hello, there. We’ve deployed https://github.com/travis-ci/travis-hub/pull/216, which fixes this issue.

Let us know if you continue to receive email. Thanks!

Imprint