Travis-CI API, CLI on Ubuntu 18+ (running on Android 6.0.1 via UserLAnd)


#1

I’m trying to explore the API in an attempt to make my own little toy that can monitor Travis + etc CI’s on my mobile since the mobile web support on each site is as bad as the API docs of Travis.

Got Ruby installed but each time I try to install Travis it fails with the only error message being the ever-so-useful

"
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - fstat(2)
"

Lovely. Tried to install RVM to fix the potentially-corrupt fresh-from-the-freaking-servers Ruby install and that pile of trash is complaining about a lack of /dev/fd; the command it gives to fix that fails as UserLAnd runs Linux in a chroot environment and doesn’t actually have permissions to create a symbolic link. So, RVM is completely useless, and could really take some hints from NVM.

Most of the fixes online are for similar issues but not this exactly and those haven’t worked as of yet. Every bug report I found opened on the Ruby project was closed without being solved, and with very little attempt to do so from the developers side.

So, are there any other CLI’s (preferably using NodeJS) which are a good-enough replacement for this broken toolchain, or does the insanely flawed and not-so-precious gem known as Ruby really have a complete stranglehold over the Travis-CI CLI?