Travis build wont start


#1

I added the .travis.yml file and no builds start… tried comiting multiple times but it doesn’t trigger anything.

Here is my travis.yml code:
language: csharp
solution: LOG330-Lab.sln
before_install:
- sudo apt-get install nunit-console
before_script:
- nuget restore LOG330-Lab.sln
after_script:
- nunit-console LOG330-LabTests/bin/Release/netcoreapp2.0/LOG330-LabTests.dll


#2

I keep getting build config is required in the requests tab, so no requests are passing.


#3

Which repo are you trying to build?


#4

the LOG330-Lab, the one where all the requests haven’t passed


#5

That’s not a complete repo name. If you are having trouble with course work at a school, I suggest asking for help from your instructor.


#6

This kind of things happen when you have a syntax error in your yml.
Check everything carefully, even spacing.


#7

I did and he didn’t help me. The complete repo name is mikaelsauriol5/LOG330-Lab.

I have the same script as my freind but i run on osx. His works and mine doesnt and i don’t know why. I’m still getting the build config error. Here’s my new script:

language: csharp
solution: LOG330-Lab.sln
mono: none
os: osx
dotnet: 2.0.0
script:

  • dotnet restore
  • dotnet test

#8

In the requests page, you should see this message:

Build config file is required via repository settings, but config is empty.