Support for building R project on Ubuntu Focal (20.04) or Bionic (18.04)

@jeroen @jimhester

Given this previous thread on the subject of Bionic, is there a prospect for having Bionic or Focal available to build R projects?

Primary reason for R projects: AFAIK you can’t have precompiled GDAL 3 or PROJ >= 6 on Xenial, while these are needed more and more.

See here for R. Bivand’s recent note on this for the rgdal package. It was the reason why we had a temporary build failure on Xenial.

Focal has GDAL 3 or PROJ 6 available already in its repo, and for Bionic they can be installed by adding the ubuntugis-unstable PPA (not on Xenial though), but when trying to use:

  • dist=focal: the build still reverted to (travis default) Xenial.

    • I see the Focal build environment is just out; but so this seems an interesting way.
  • dist=bionic: the build does run Ubuntu Bionic, however it halts here because of an inaccessible https://travis-ci.rstudio.org/R-4.0.0-bionic.xz:

    $ curl -fLo /tmp/R-4.0.0-$(lsb_release -cs).xz https://travis-ci.rstudio.org/R-4.0.0-$(lsb_release -cs).xz
    
    674curl: (22) The requested URL returned error: 403
    

As a sidenote (maybe that should go in a separate topic), I see that the build automatically does a

sudo add-apt-repository -y "ppa:ubuntugis/ppa"

However on Bionic (and above) this will (currently) not suffice: this is the ubuntugis-stable PPA which only holds version 2 of GDAL and PROJ 5.

Considering the above, I’d suggest to add the ubuntugis-unstable PPA for Bionic.

I’ve just got that same error that you mention for bionic. However, I don’t think that’s the reason, but that maybe there’s been a change on the permissions of the page.

In this PR Travis run r-raster-vector-geospatial#325 from a month ago it worked fine, however in a new one from today it shows the 403 forbidden error you mentioned. And for what I’ve found in the forum it may be a temporary problem (though I don’t know what’s the best way to report it).

Imprint