Reduce the number of repositories in the list

This sounds like an issue I had as well roughly 21 days ago. I also couldn’t figure it out at first days and then support said to me I have to do migration from travis-ci.org (which I did and I had a bad time for many days afterwards fearing my project go bonkers - I should have informed myself more before click).

One left in the aftermath of it is that now there are way too many github repositories in my travis-ci.com account. Did you figure out how to reduce the list to one, maybe two selected repositories? If so, I would love to hear about that.

I don’t think that is the issue. I only started this about two days ago so I am probably up to date. The only thing I can think of is that when it started up I said I only wanted travis for one repository, I chose the json-create repository mentioned above, then there was some kind of error, and then I said “All repositories” since it was refusing to work with just one. So perhaps there was some kind of overlap or something.

Most of my things were never designed to be installed from the git repository so I am just testing out a way to make that possible with the one module json-create.

I was surprised to see such an odd occurrence since travis CI has been going for a few years now.

Thanks for the help everyone, but it is still not working yet.

@ktomk That’s an unrelated problem.

You can star select repos on the Dashboard page to see them at the top.

@native-api yes, thanks for the initiatve, however I was no concerned about the dashboard. it is just that my Travis com account has all my github repositories in there but I only want to have in there only one repository of them all for example.

I guess you can allow Travis Github app access to only the select repos – but I dunno what the effect would be.

1 Like

Just wanted to edit it in, seeing your reply: The effect is the wanted one, I just did this and could reduce to one repository (and another orphaned one which is not from my account, maybe some old collaborator setting, no clue).

Basically this worked. Will re-add some I know I have builds for and see if there are some side-effects.

1 Like

Okay, this is interesting.

I added another one, and it did not appear. Most likely because it runs on .org and is not migrated.

And then I added another one, which did appear. That one did never run on .org.

So the list of repositories on .com is filtered and does not give message why a certain repository is not shown.

@native-api this is what the screenshot Can't find a repository that I just added .travis.yml to - #3 by benkasminbullock reminded me. When I started with .com I was missing exactly like that repositories. The fix in the end may be different as I needed to migrate otherwise it won’t appear, but I also got quire some of my repositories in the list just missing some.

1 Like
Imprint