Puppeteer not working on Windows container


#1

I tried enabling Windows build in an open source project (stylable) that uses Travis.
puppeteer seems to fail launching Chrome:
https://travis-ci.org/wix/stylable/jobs/441261955

Error: Failed to launch chrome!
@stylable/webpack-plugin: [1014/123449.724:ERROR:main_dll_loader_win.cc(134)] Failed to load Chrome DLL from C:\Users\travis\build\wix\stylable\node_modules\puppeteer\.local-chromium\win64-594312\chrome-win\chrome.dll: The specified module could not be found. (0x7E)
@stylable/webpack-plugin: TROUBLESHOOTING: https://github.com/GoogleChrome/puppeteer/blob/master/docs/troubleshooting.md
@stylable/webpack-plugin: 
@stylable/webpack-plugin:       at onClose (C:\Users\travis\build\wix\stylable\node_modules\puppeteer\lib\Launcher.js:339:14)
@stylable/webpack-plugin:       at ChildProcess.helper.addEventListener (C:\Users\travis\build\wix\stylable\node_modules\puppeteer\lib\Launcher.js:329:60)
@stylable/webpack-plugin:       at Process.ChildProcess._handle.onexit (internal/child_process.js:240:12)

Karma support for Windows
#2

I’m having the same issue. I’ve tried install chrome through choco and it get installed but it seems like it can’t run.
https://travis-ci.org/wardpeet/lighthouse/jobs/448723334

I’ve ran all commands on my own windows machine using git bash and it works but on travis it seems to fail.