"Installing Google Chrome stable" but I can't find it anywhere

In my .travis.yml file I have:

addons:
  chrome: stable

And in the build output I see:

Installing Google Chrome stable

However, I can’t find an install anywhere. It doesn’t seem to be on PATH and it doesn’t seem to be in either Program Files or AppData folders. Is it actually being installed? If so, where to?

The addon is not currently supported on Windows at the moment. https://docs.travis-ci.com/user/chrome

That was the conclusion I came to, though since the text had been output I thouht maybe it was supposed to work.

I’ve worked around it by just installing with Chocolatey for now. Thanks!

1 Like

@DanTup Can you please put the choco commands to install chrome on the windows which worked for you. I am trying choco install googlechrome this but it gives me an error.

https://community.chocolatey.org/packages/GoogleChrome

@native-api I had used the same command itself. But getting the issue as follows:

Failures

112 - googlechrome (exited -1) - Error while running 
'C:\ProgramData\chocolatey\lib\GoogleChrome\tools\chocolateyInstall.ps1'.

Here you can see the Travis build Logs: Travis CI - Test and Deploy with Confidence

Looking at that script, it points to the latest available version rather than a specific version. So I’d say it’s safe to pass --ignore-checksums as the error message suggests.

(There’s also no need to choco upgrade a package that you’ve just installed.)

@rajshah001 this is what I used, although I’m no longer using Travis (using GH Actions) so I don’t know for sure it still works reliably.

if [[ $TRAVIS_OS_NAME == "windows" ]]; then
    echo Installing Google Chrome Stable...
    # Install Chrome via Chocolatey while `addons: chrome` doesn't seem to work on Windows yet
    # https://travis-ci.community/t/installing-google-chrome-stable-but-i-cant-find-it-anywhere/2118
    choco install googlechrome --acceptlicense --yes --no-progress --ignore-checksums
fi
2 Likes

Hi,

Can anybody help me to out from this? I facing an issue with chrome browser installation.
Below error is displayed every time :

The command "mocha test/testFile.js" exited with 7.
WebDriverError: unknown error: cannot find Chrome binary

In my .travis.yml file I have:

language: node_js
node_js: 
 - node
os: windows
addons:
 chrome: stable
install: 
 - npm install
scripts:
 - mocha test/testFile.js
Imprint