"Not using downloaded repomd.xml because it is older than what we have" on yum install

bug

#1

I’ve hit a strange problem installing ccache in manylinux1 (CentOS 5-based) docker image: https://travis-ci.org/native-api/opencv-python/jobs/457726222#L647

+ yum install -y ccache
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Thu Mar 30 15:57:07 2017
  Downloaded: Thu Mar 30 15:57:06 2017
Setting up Install Process
No package ccache available.
Nothing to do

It happens consistently in Travis environment but doesn’t happen if I run the same Docker image locally.

For the time being, I was able to workaround it with yum clean metadata.

My best guess is that local timezone in Travis workers does not account for a leap second, so the same UNIX timestamp produces a datetime that’s one second bigger.


#2

I stay corrected; it does happen locally if I use the very same Docker image.