No debug shell on s390x

I tried to restart a s390x job in debug mode, but it errored out very early with:

Setting up debug tools.
cat: write error: Broken pipe
Preparing debug sessions.
/home/travis/.debug/travis_debug.sh: line 42: /home/travis/.debug/tmate: cannot execute binary file: Exec format error

All remaining steps, including caching and deploy, will be skipped.

https://travis-ci.org/szeder/git/jobs/616778307#L40

The first step would be to have appropriate tmate binaries built.

This can be the start of a long yak shaving; tmate uses Alpine docker images to build its binaries, but it also relies on other apk packages such as zlib and ssl to be available. My initial testing suggests to me that some of these packages are not available to Z. And these will have to be resolved before we can offer debug builds.

You tried to build tmate on arm64, not s390x:

  - arch: arm64
    env: PLATFORM=s390x

https://travis-ci.org/BanzaiMan/tmate/builds/616858320#L2

The tests happen on Docker. arm64 is just the host.

https://travis-ci.org/BanzaiMan/tmate/builds/616858320#L36

OK, got it. Thanks for looking into it.

Is arm64 big or little endian?

You can use lscpu to get the byte order

lscpu reports that arm64 is little endian.

But perhaps this is something worth mentioning in the related documentation?

Imprint