Long running HTTP request on Linux

My build makes a long running HTTP request that receives no response if it runs over ~8 minutes. I’m wondering if Travis is running a firewall that kills long running requests or perhaps there is something I can configure on the build instance to increase this timeout?

P.S. This issue is not related to Travis killing the job due to no output after 10 minutes.

This issue does not occur on the macOS instances. I assume it must be some Linux instance configuration setting.

I’ve tried setting:

sysctl net.ipv4.tcp_keepalive_time
sysctl net.ipv4.tcp_keepalive_intvl
sysctl net.ipv4.tcp_keepalive_probes

But none seem to resolve the issue.

Imprint