Connectivity issues


The job is failing because it is taking too long to download a file The problem is random. There are other jobs in the build which is downloading the files fine.

I started to get this problem since 3rd May 2019. Before that it used to work fine. I think Travis is facing slow connectivity issues.


I have the same issue with other connections (newrelic, alpine linux repository), also started a couple days ago and still is happening

I’m seeing the same problem in this private build when bundler is downloading gems:

It works on the second or third try most of the time. As @subhojit777 mentioned, this only started happening very recently.

We am experiencing similar issues with an Elixir project. Connections time out all the time. Especially when building a docker image and downloading dependencies.

The problem is still there today, although it has been reduced very much.

Please see for updates. Thanks.

1 Like

It’s definitely better now. But we are still experiencing issues

Even after the Monitoring update of May 07, 2019 - 16:32 UTC the situation is still the same for us.

Do you have any workaround? The solution with --network=host can’t be done for us.

Sorry for the continued troubles, @gergo-papp!

Can you share a link/URL to a build showing the issues you are still having? Also, could you give us a short description of what’s happening and include a copy of the error message we should look at?


I still have connectivity issues on some builds, e.g.

Same files can be downloaded just fine on non-travis environments.

It says the issue has been fixed. But I am still getting the issues That line is downloading a file - its working fine outside Travis. indicates that your job is trying to download files from This is often a problem due to the shared IP addresses our jobs use, since GitHub imposes a rate limit (60/hour) on anonymous API requests based on IP addresses.

Adding your own token, even one without any scope, to make these requests should solve the problem.

Please check with (which appears to be hosted by GitLab Enterprise) for a similar API rate limiting issue.

Looks like the problem is still there. I tried changing the source, the job is still hanging up

Also, there are errors like could not be downloaded: SSL: Handshake timed out - And the error is random, it downloaded fine here

These jobs used to work fine before.

I added a token for the requests, but the problem is still happening

@BanzaiMan The problem was fixed yesterday. Thanks for your support.

We are still seeing issued with Elixir dependencies. It’s all related to network issues and it still happens on our builds very often (almost 50% of our builds time out or have network issues).

This build is just one example on a demo repository:

However our other builds randomly fail with other errors as well (especially when downloading the “hex” and “rebar” package manages and getting 3rd party dependencies using “mix deps.get”).
This doesn NOT related to running inside a docker container.