Library on Crystal doesn't allow 1.0

Hi everyone, glad you updated travis-ci with the new crystal 1.0 but I met an issue now, I have this error :
$ pip install --user awscli

before_install.2

0.00s$ export PATH=$PATH:$HOME/.local/bin

5.58s$ shards install

Resolving dependencies

Fetching https://github.com/kemalcr/kemal.git

Fetching https://github.com/luislavena/radix.git

Fetching https://github.com/jeromegn/kilt.git

Fetching https://github.com/crystal-loot/exception_page.git

Fetching https://github.com/elbywan/cryomongo.git

Fetching https://github.com/elbywan/bson.cr.git

Fetching https://github.com/crystal-lang/crystal-db.git

Unable to satisfy the following requirements:

  • crystal (~> 0.35, >= 0.35.0) required by kemal 0.27.0

  • crystal (~> 0.35, >= 0.35.0) required by cryomongo 0.3.3+git.commit.d2e1f31fdf879c26aaf961eda2cb55dfa3f69f0a

  • crystal (< 1.0.0) required by radix 0.3.9

  • crystal (< 1.0.0) required by kilt 0.4.0

  • crystal (~> 0.33, >= 0.33.0) required by exception_page 0.1.4

Failed to resolve dependencies, try updating incompatible shards or use --ignore-crystal-version as a workaround if no update is available.

What is the best solution to troubleshoot this problem on travis ? Actually on my own dockers I just changed and add --ignore-crystal-version and it is working.
Thanks Robin

This isn’t a Travis issue. See Weird "shards outdated" output (Crystal 1.0.0) - Help & Support - The Crystal Programming Language Forum.

1 Like
Imprint