Installing OracleJDK 11 failed

Installing oraclejdk11

535W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packagecloud.io/github/git-lfs/ubuntu trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6B05F25D762E3157

536W: Failed to fetch https://packagecloud.io/github/git-lfs/ubuntu/dists/trusty/InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6B05F25D762E3157

537W: Some index files failed to download. They have been ignored, or old ones used instead.

538OK

539W: The repository 'https://packages.adoptium.net/artifactory/deb trusty Release' is not signed.

540W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://packagecloud.io/github/git-lfs/ubuntu trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6B05F25D762E3157

541W: Failed to fetch https://packagecloud.io/github/git-lfs/ubuntu/dists/trusty/InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6B05F25D762E3157

542W: Some index files failed to download. They have been ignored, or old ones used instead.

543E: Unable to locate package temurin-11-jdk

544$ export JAVA_HOME=/usr/lib/jvm/temurin-11-jdk-amd64

545$ export PATH="/usr/lib/jvm/temurin-11-jdk-amd64/bin:/home/travis/bin:/home/travis/.local/bin:/opt/pyenv/shims:/home/travis/.rvm/gems/ruby-2.4.1/bin:/home/travis/.rvm/gems/ruby-2.4.1@global/bin:/home/travis/.rvm/rubies/ruby-2.4.1/bin:/home/travis/gopath/bin:/home/travis/.gimme/versions/go1.7.4.linux.amd64/bin:/usr/local/clang-3.9.0/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/android-sdk/tools:/usr/local/android-sdk/platform-tools:/home/travis/.rvm/bin:/opt/pyenv/bin"

546update-java-alternatives: directory does not exist: /usr/lib/jvm/temurin-11-jdk*

Seems Travis keys for git-lfs are wrong X_x

Just changed my distro from trusty to focal and I get these errors

travis_fold:start:install_jdk
e[0Ke[33;1mInstalling oraclejdk11e[0m
W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/main/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/restricted/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/universe/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/multiverse/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/main/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/restricted/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/universe/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/multiverse/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/main/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/restricted/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/universe/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise/multiverse/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/main/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/restricted/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/universe/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/multiverse/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/main/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/restricted/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/universe/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/multiverse/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/main/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/restricted/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/universe/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-updates/multiverse/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/main/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/restricted/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/universe/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/multiverse/source/Sources  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/main/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/restricted/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/universe/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/multiverse/binary-amd64/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/main/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/restricted/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/universe/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://us-east1.gce.archive.ubuntu.com/ubuntu/dists/precise-backports/multiverse/binary-i386/Packages  404  Not Found [IP: 35.196.128.168 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/main/source/Sources  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/restricted/source/Sources  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/universe/source/Sources  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/multiverse/source/Sources  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/main/binary-amd64/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/restricted/binary-amd64/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/multiverse/binary-amd64/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/main/binary-i386/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://apt.postgresql.org/pub/repos/apt/dists/precise-pgdg/main/binary-amd64/Packages  404  Not Found [IP: 147.75.85.69 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/universe/binary-i386/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.91.38 80]

W: Failed to fetch http://apt.postgresql.org/pub/repos/apt/dists/precise-pgdg/main/binary-i386/Packages  404  Not Found [IP: 147.75.85.69 80]

W: Failed to fetch http://ppa.launchpad.net/rwky/ppa/ubuntu/dists/precise/main/binary-amd64/Packages  403  Forbidden

W: Failed to fetch http://ppa.launchpad.net/rwky/ppa/ubuntu/dists/precise/main/binary-i386/Packages  403  Forbidden

W: Failed to fetch http://downloads-distro.mongodb.org/repo/debian-sysvinit/dists/dist/10gen/binary-amd64/Packages  Undetermined Error [IP: 52.21.89.200 80]

W: Failed to fetch http://downloads-distro.mongodb.org/repo/debian-sysvinit/dists/dist/10gen/binary-i386/Packages  Undetermined Error [IP: 52.21.89.200 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
--2022-06-06 11:53:57--  https://apt.corretto.aws/corretto.key
Resolving apt.corretto.aws (apt.corretto.aws)... 18.67.0.24, 18.67.0.127, 18.67.0.31, ...
Connecting to apt.corretto.aws (apt.corretto.aws)|18.67.0.24|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1695 (1.7K) [binary/octet-stream]
Saving to: `STDOUT'

     0K .                                                     100% 1.31G=0s

Not sure why it’s trying to access precise distro

Hey all,

A temporary fix while we are waiting for InfraOps to patch this is as follows, and please note, the must be used before the before_install script hook:

before_install:
  - curl -s "https://get.sdkman.io" | bash
  - source "$HOME/.sdkman/bin/sdkman-init.sh"
  - sdk install java 11.0.12-open
  - sdk use java 11.0.12-open

And remove the following:

jdk:
  - openjdk11

This should do the trick for now, we are still doing some heavy investigating.

any rough sense of ETA on the fix? and can you provide instructions for OracleJDK13 ?

should be similar to this

before_install:
  - curl -s "https://get.sdkman.io" | bash
  - source "$HOME/.sdkman/bin/sdkman-init.sh"
  - sdk install java 13.x.y-oracle
  - sdk use java 13.x.y-oracle

source: JDK Distributions - SDKMAN! the Software Development Kit Manager

Hey folks,

Could you please share the build links that the error occurs for your repositories?

Thanks