Install location for iisexpress

Hi everyone.
I’m trying to install the iisexpress server on travis.
Here’s my .travis.yml -

os: windows

language: node_js

- '10'

  - choco install iisexpress
  - iisexpress 

I do see that iisexpress is successfully installed in travis logs -

51.42s$ choco install iisexpress
Chocolatey v0.10.11
Installing the following packages:
By installing you accept licenses for the packages.
Progress: Downloading DotNet4.0 4.0.30319.20141222... 100%
Progress: Downloading iisexpress 100%
DotNet4.0 v4.0.30319.20141222 [Approved]
dotnet4.0 package files install completed. Performing other installation steps.
Microsoft .Net 4.0 Framework is already installed on your machine.
 The install of dotnet4.0 was successful.
  Software install location not explicitly set, could be in package or
  default install location if installer.
iisexpress v10.0.0.20181007 [Approved]
iisexpress package files install completed. Performing other installation steps.
Downloading iisexpress 64 bit
  from ''
Progress: 100% - Completed download of C:\Users\travis\AppData\Local\Temp\chocolatey\iisexpress\\iisexpress_amd64_en-US.msi (9.09 MB).
Download of iisexpress_amd64_en-US.msi (9.09 MB) completed.
Hashes match.
Installing iisexpress...
iisexpress has been installed.
  iisexpress may be able to be automatically uninstalled.
 The install of iisexpress was successful.
  Software installed as 'msi', install location is likely default.
Chocolatey installed 2/2 packages. 
 See the log for details (C:\ProgramData\chocolatey\logs\chocolatey.log).

But when I run the iisexpress command, I get iisexpress command not found error.

  • I have tried using iisexpress.exe command. But that doesn’t work either. (Windows n00b alert)
  • When I install a package using choco, I see that it’s not added to PATH. Is this correct?
  • If so, where is the default install location for choco packages?

Any help would be much appreciated.

Thank you

Chocolatey updates the system PATH in the Registry, but it doesn’t get applied in any running applications. To reload it from the Registry you’ll need to use RefreshEnv.cmd (for a cmd.exe session) or RefreshEnv.ps1 (for a PowerShell session).

So, keeping in mind that your .travis.yml commands run inside a Git Bash shell, instead of iisexpress.exe you’ll need to run:

cmd.exe //c "RefreshEnv.cmd & iisexpress.exe"