HTTP/2 403 - Connection state changed (MAX_CONCURRENT_STREAMS == 128)!

I’m using a curl POST to trigger builds, and everything went fine, until the server started to return

* Connection state changed (MAX_CONCURRENT_STREAMS == 128)!
* We are completely uploaded and fine
< HTTP/2 403 
< date: Thu, 02 Apr 2020 17:22:06 GMT
< content-type: application/json
< content-length: 433
< vary: Accept-Encoding
< strict-transport-security: max-age=15724800; includeSubDomains
< x-endpoint: Travis::API::V3::Services::Requests::Create
< x-oauth-scopes: public,private
< vary: Accept-Encoding
< x-rack-cache: invalidate, pass
< x-request-id: 85478f61e8d28696f0d3dced8acfadc8
< access-control-allow-origin: *
< access-control-allow-credentials: true
< access-control-expose-headers: Content-Type, Cache-Control, Expires, Etag, Last-Modified, X-Request-ID
< 
{
  "@type": "error",
  "error_type": "insufficient_access",
  "error_message": "operation requires create_request access to repository",
  "resource_type": "repository",
  "permission": "create_request",
  "repository": {
    "@type": "repository",
    "@href": "/repo/28388005",
    "@representation": "minimal",
    "id": 28388005,
    "name": "arm-none-eabi-gcc-xpack",
    "slug": "xpack-dev-tools/arm-none-eabi-gcc-xpack"
  }
* Connection #0 to host api.travis-ci.org left intact
}* Closing connection 0

I did not change any settings in GitHub.

Any Idea what went wrong? Is the Travis server too busy to accept some requests?

As suggested in another thread, I disabled and re-enabled the connection to the GitHub repository and the problem went away.

Weird…

Imprint