Getting error "Package required and available but unsuitable version: EpiModel"

@jeroen @jimhester Hello!

Link to Travis CI job
I am getting the following error in the travis build:

* checking package dependencies ... ERROR
Package required and available but unsuitable version: ‘EpiModel’

Though the package builds completely fine in my local computer and I have never gotten this problem before. My DESCRIPTION file goes like:

Package: CampNetworkSimulator
Title: CNS(CampNetworkSimulator)
Version: 0.0.1
Authors@R:
    person(given = "Luis",
           family = "Chaves",
           role = c("aut", "cre"),
           email = "lc5415@ic.ac.uk")
Description: Wrapper around EpiModel with addition of custom modules to simulate COVID19 in refugee camps.
License: MIT + file LICENSE
Encoding: UTF-8
LazyData: true
Roxygen: list(markdown = TRUE)
RoxygenNote: 7.1.1
Depends:
    R (>= 4.0.0)
Imports:
    networkDynamic,
    pheatmap,
    plotly,
    animation,
    dplyr,
    EpiModel,
    ggplot2,
    intergraph,
    igraph,
    ergm,
    tidyr,
    network,
    foreach,
    doParallel,
    magrittr,
    tergmLite

and my .travis.yml like:

language: r

before_install:
 if [ $TRAVIS_OS_NAME = linux ]; then sudo apt-get install libmagick++-dev; else brew install bar; fi
os:
  - linux
  - osx
  - windows
pandoc: false
latex: false

I am not enforcing any specific version in any package and it the last build I tried upping the R requirement to above 4.0.0 but that did not fix the problem

Imprint