Error with file-encryption

Build error:

Github Repo for code:

What am I doing wrong?

There are no variables encrypted_2f5e3e66b395_key or encrypted_2f5e3e66b395_iv in your configuration.

Add them to .travis.yml or repository settings in Travis UI according to

What should the values be for those variables? How do I get them?

This looks like the confusion with .org and .com. You set up the file encryption against .org (the default) and it works there However, you are looking at .com now, which requires a new set of env vars.

I suggest:

  1. Setting up file encryption against .com (with travis encrypt-file --pro …)
  2. Disable builds on .org, and migrate data to .com if you haven’t done so already.
1 Like

How do I disable builds on .org?

You can disable them on your account page: by clicking the toggle beside them.

You’ll be able to migrate your repositories to by clicking the “Sign up for the beta” button on the same page.

Hope this helps!

1 Like