Encrypt-file after migrating from travis-ci.org to travis-ci.com

I recently moved a repository from travis-ci.org to travis-ci.com. Things seemed to have moved and built fine. But, I am running into an issue when I invoke "travis encrypt-file sample.txt” from one of those repositories using the Travis CI CLI.

I did the following -
% travis endpoint --com --set-default
API endpoint: https://api.travis-ci.com/ (stored as default)
% travis endpoint
API endpoint: https://api.travis-ci.com/
% travis encrypt-file sample.txt
encrypting r.tar for
storing result as sample.txt.enc
storing secure env variables for decryption
This repository has been migrated to travis-ci.com. Modifications to this repository, it’s builds, and jobs are disabled on travis-ci.org. If you have any questions please contact us at support@travis-ci.com

Previously, I could get an openssl key pair generated/added, but now I just get the message “This repository has been migrated… Modifications are disabled…”. I also did a “travis login --com” at some point, but that does not change the result of encrypt-file.

Has anyone seen and solved this issue? Any help will be greatly appreciated.

Thanks.

Looks like explicitly using --com “travis encrypt-file sample.txt --com” worked. So, the issue seems to be with encrypt-file ignoring the default endpoint.

Imprint