Deploy fails with Aws::S3::Errors::SignatureDoesNotMatch

https://travis-ci.org/seiu503/member-app-2019/builds/609016742 (error at line 1984)

my last few builds have failed with this message:
/home/travis/.rvm/gems/ruby-2.4.5/gems/aws-sdk-core-2.11.393/lib/seahorse/client/plugins/raise_response_errors.rb:15:in call’: The request signature we calculated does not match the signature you provided. Check your key and signing method. (Aws::S3::Errors::SignatureDoesNotMatch)`

i didn’t make any changes to these keys and they have been working fine for months. when the build failed i deleted and re-added the AWS key and secret as Travis repo-specific ENV variables, then when that didn’t work i generated a new key and secret in the AWS console, added them in Travis Settings, and tried again (twice!). still doesn’t work. neither my key nor secret has any bash special characters.

when i google this error message i see a bunch of issues from 4-5 years ago where the fix was updating the aws sdk gem or resetting the system time on the server. i have confirmed server time is correct and don’t know how or where i would need to update the gem, but most of these issues were from 2014-15 so not sure if that’s even relevant any more.

any idea why this would still be failing?

+1

I has same issue.

You are using the plain text value in the secure value. We rolled out additional changes to data processing so that we can prevent accidental exposures of these secrets.

Your configuration was working before because we were passing through values when the decrpytion fails in such a case.

Please try changing this configuration to:

secret_acces_key: $AWS_SECRET_KEY

and report the results.

that worked! thank you!

1 Like
Imprint