Default branch change issues

I changed the default branch on one of my repositories from “master” to “main.” However, on the website, the badge which purports to display the build status of the default branch, still shows the master branch. Furthermore, while builds are run on pull requests, Travis seems to have stopped reporting the status to GitHub.

For example this PR triggered a Travis build but the status does not show on GitHub. You can also see on the build page that the badge still refers to the master branch.

Hello, there. In this particular case, we weren’t able to post status on GitHub because we didn’t have valid token to do so on your behalf. Could you try going to

https://travis-ci.org/account/repositories

and resyncing data? You can restart this build (one of the jobs will do), or push a new commit to the PR topic branch.

Thanks.

I tried resyncing previously, but I tried again and restarted the build. I’m still not seeing the status posted. I will note that when I pressed the sync button, the loading animation never went away after a fairly long wait but upon refreshing the page, it said things were synced less than a minute ago.

In any case, it would be helpful if this problem was surface somewhere in the UI. I could imagine not noticing that the build status isn’t reported and merging a PR that fails tests.

Imprint